GetDefaultHookAngle Method


Rebar Shape Get Default Hook Angle Method

Get the hook angle, expressed as an integral number of degrees (common values are 0, 90, 135, and 180).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public int GetDefaultHookAngle(
	int index
)

Parameters

index Int32
0 for the starting hook, 1 for the ending hook.

Return Value

Int32
Exceptions
Exception Condition
ArgumentOutOfRangeException index must be 0 or 1.
Remarks
Replaces the method GetHookAngle() from prior releases.
See Also