GetDefaultHookAngle Method


Rebar Shape Get Default Hook Angle Method

Note: This API is now obsolete.

Get the hook angle, expressed as an integral number of degrees (common values are 0, 90, 135, and 180).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2026 and may be removed in a later version of Revit. Please use RebarShape.GetTerminationsData().HookAngleAtStart or RebarShape.GetTerminationsData().HookAngleAtEnd instead.")]
public int GetDefaultHookAngle(
	int end
)

Parameters

end Int32
0 for the starting hook, 1 for the ending hook.

Return Value

Int32
Exceptions
Exception Condition
ArgumentOutOfRangeException end must be 0 or 1.
Remarks
Replaces the method GetHookAngle() from prior releases.
See Also