Exports the schedule data to a text file.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- folder
- Type: System String
Path to the location where the file will be saved.
- name
- Type: System String
Name of file.
- options
- Type: Autodesk.Revit.DB ViewScheduleExportOptions
Options that relate to schedule export.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | NullOrEmpty -or- Contains invalid characters. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions FileAccessException | The path indicated could not be accessed. |
Autodesk.Revit.Exceptions InvalidPathArgumentException | The folder does not exist. |