Export Method


Exports the schedule data to a text file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public void Export(
	string folder,
	string name,
	ViewScheduleExportOptions options
)
Visual Basic
Public Sub Export ( _
	folder As String, _
	name As String, _
	options As ViewScheduleExportOptions _
)
Visual C++
public:
void Export(
	String^ folder, 
	String^ name, 
	ViewScheduleExportOptions^ options
)

Parameters

folder
Type: SystemString
Path to the location where the file will be saved.
name
Type: SystemString
Name of file.
options
Type: Autodesk.Revit.DBViewScheduleExportOptions
Options that relate to schedule export.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException NullOrEmpty -or- Contains invalid characters.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsFileAccessException The path indicated could not be accessed.
Autodesk.Revit.ExceptionsInvalidPathArgumentException The folder does not exist.

See Also