Removes a join between two elements.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document containing the two elements.
- firstElement
- Type: Autodesk.Revit.DB Element
The first element to be unjoined.
- secondElement
- Type: Autodesk.Revit.DB Element
The second element to be unjoined. This element must be joined to the fist element.
Remarks
This functionality is not available for family documents.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | document is not a project document. -or- The element firstElement was not found in the given document. -or- The element secondElement was not found in the given document. -or- The elements are not joined. -or- The elements cannot be unjoined. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | Please remove or add segments on curtain grids instead of joining or unjoining geometry of the panels. |