UnjoinGeometry Method


Removes a join between two elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static void UnjoinGeometry(
	Document document,
	Element firstElement,
	Element secondElement
)
Visual Basic
Public Shared Sub UnjoinGeometry ( _
	document As Document, _
	firstElement As Element, _
	secondElement As Element _
)
Visual C++
public:
static void UnjoinGeometry(
	Document^ document, 
	Element^ firstElement, 
	Element^ secondElement
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document containing the two elements.
firstElement
Type: Autodesk.Revit.DBElement
The first element to be unjoined.
secondElement
Type: Autodesk.Revit.DBElement
The second element to be unjoined. This element must be joined to the fist element.

Remarks

This functionality is not available for family documents.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException document is not a project document. -or- The element firstElement was not found in the given document. -or- The element secondElement was not found in the given document. -or- The elements are not joined. -or- The elements cannot be unjoined.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException Please remove or add segments on curtain grids instead of joining or unjoining geometry of the panels.

See Also