Join |
Removes a join between two elements.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static void UnjoinGeometry(
Document document,
Element firstElement,
Element secondElement
)
Parameters

Exception | Condition |
---|---|
ArgumentException | document is not a project document. -or- The element firstElement was not found in the given document. -or- The element secondElement was not found in the given document. -or- The elements are not joined. -or- The elements cannot be unjoined. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | Please remove or add segments on curtain grids instead of joining or unjoining geometry of the panels. |

This functionality is not available for family documents.