Gets the user-visible name for a unit.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- unitTypeId
- Type: Autodesk.Revit.DB ForgeTypeId
Identifier of the unit to get the user-visible name.
Remarks
The name is obtained in the current Revit language.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Cannot find DisplayUnitTypeInfo for the given unit identifier. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |