GetLabelForUnit Method


Gets the user-visible name for a unit.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public static string GetLabelForUnit(
	ForgeTypeId unitTypeId
)
Visual Basic
Public Shared Function GetLabelForUnit ( _
	unitTypeId As ForgeTypeId _
) As String
Visual C++
public:
static String^ GetLabelForUnit(
	ForgeTypeId^ unitTypeId
)

Parameters

unitTypeId
Type: Autodesk.Revit.DBForgeTypeId
Identifier of the unit to get the user-visible name.

Remarks

The name is obtained in the current Revit language.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException Cannot find DisplayUnitTypeInfo for the given unit identifier.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also