Transforms an envelope ( BoundingBoxUV ) for one surface to an envelope for a coincident but differently parameterized surface.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2021
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- uvDomain
- Type: Autodesk.Revit.DB BoundingBoxUV
The original surface envelope.
Return Value
If successful a new BoundingBoxUV transformed surface envelope, otherwise a null reference ( Nothing in Visual Basic) .Remarks
This method succeeds in the case when the uv-parameter transform between the surfaces has a simple form, that commonly occurs for analytic surfaces, such that the image of the input envelope under the transform is itself a rectangular region aligned with the UV coordinate axes.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | uvDomain is not set. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |