TransformUVDomainIfPossible Method


Transforms an envelope (BoundingBoxUV) for one surface to an envelope for a coincident but differently parameterized surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2021

Syntax

C#
public BoundingBoxUV TransformUVDomainIfPossible(
	BoundingBoxUV uvDomain
)
Visual Basic
Public Function TransformUVDomainIfPossible ( _
	uvDomain As BoundingBoxUV _
) As BoundingBoxUV
Visual C++
public:
BoundingBoxUV^ TransformUVDomainIfPossible(
	BoundingBoxUV^ uvDomain
)

Parameters

uvDomain
Type: Autodesk.Revit.DBBoundingBoxUV
The original surface envelope.

Return Value

If successful a new BoundingBoxUV transformed surface envelope, otherwise a null reference (Nothing in Visual Basic).

Remarks

This method succeeds in the case when the uv-parameter transform between the surfaces has a simple form, that commonly occurs for analytic surfaces, such that the image of the input envelope under the transform is itself a rectangular region aligned with the UV coordinate axes.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException uvDomain is not set.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also