Transform |
Transforms an envelope ( BoundingBoxUV ) for one surface to an envelope for a coincident but differently parameterized surface.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- uvDomain BoundingBoxUV
- The original surface envelope.
Return Value
BoundingBoxUVIf successful a new BoundingBoxUV transformed surface envelope, otherwise .

Exception | Condition |
---|---|
ArgumentException | uvDomain is not set. |
ArgumentNullException | A non-optional argument was null |

This method succeeds in the case when the uv-parameter transform between the surfaces has a simple form, that commonly occurs for analytic surfaces, such that the image of the input envelope under the transform is itself a rectangular region aligned with the UV coordinate axes.