Checks whether the specified element will be treated as pinned for the purposes of selection.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document containing the element.
- element
- Type: Autodesk.Revit.DB Element
The element to check.
Return Value
True if the specified element should be treated as pinned for selection purposes, false otherwise.Remarks
To improve usability, the option to disable pinned selection has some additional intelligence beyond simply checking the pinned status. For example, if a model group is pinned, the corresponding attached detail group will also be treated as pinned for the purposes of selection. If this method returns true, the specified element will not be selectable when selection of pinned elements is disabled.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |