ElementSelectsAsPinned Method


Selection UIOptions Element Selects As Pinned Method

Checks whether the specified element will be treated as pinned for the purposes of selection.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool ElementSelectsAsPinned(
	Document document,
	Element element
)

Parameters

document Document
The document containing the element.
element Element
The element to check.

Return Value

Boolean
True if the specified element should be treated as pinned for selection purposes, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
To improve usability, the option to disable pinned selection has some additional intelligence beyond simply checking the pinned status. For example, if a model group is pinned, the corresponding attached detail group will also be treated as pinned for the purposes of selection. If this method returns true, the specified element will not be selectable when selection of pinned elements is disabled.
See Also