Selection |
Checks whether the specified element will be treated as pinned for the purposes of selection.
Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
Return Value
BooleanTrue if the specified element should be treated as pinned for selection purposes, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

To improve usability, the option to disable pinned selection has some additional intelligence beyond simply checking the pinned status. For example, if a model group is pinned, the corresponding attached detail group will also be treated as pinned for the purposes of selection. If this method returns true, the specified element will not be selectable when selection of pinned elements is disabled.