Adds an embedded ScheduleDefinition.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- categoryId
- Type: Autodesk.Revit.DB ElementId
The category ID of elements to display in the embedded schedule.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | categoryId is not the ID of a category that can be used for an embedded ScheduleDefinition in this ScheduleDefinition. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Mechanical Electrical Piping. |
Autodesk.Revit.Exceptions InvalidOperationException | This ScheduleDefinition is not a kind of schedule that supports adding an embedded ScheduleDefinition. -or- This ScheduleDefinition already has an embedded ScheduleDefinition. |