AddEmbeddedSchedule Method


Adds an embedded ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public void AddEmbeddedSchedule(
	ElementId categoryId
)
Visual Basic
Public Sub AddEmbeddedSchedule ( _
	categoryId As ElementId _
)
Visual C++
public:
void AddEmbeddedSchedule(
	ElementId^ categoryId
)

Parameters

categoryId
Type: Autodesk.Revit.DBElementId
The category ID of elements to display in the embedded schedule.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException categoryId is not the ID of a category that can be used for an embedded ScheduleDefinition in this ScheduleDefinition.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsDisabledDisciplineException None of the following disciplines is enabled: Mechanical Electrical Piping.
Autodesk.Revit.ExceptionsInvalidOperationException This ScheduleDefinition is not a kind of schedule that supports adding an embedded ScheduleDefinition. -or- This ScheduleDefinition already has an embedded ScheduleDefinition.

See Also