AddEmbeddedSchedule Method


Schedule Definition Add Embedded Schedule Method

Adds an embedded ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddEmbeddedSchedule(
	ElementId categoryId
)

Parameters

categoryId ElementId
The category ID of elements to display in the embedded schedule.
Exceptions
Exception Condition
ArgumentException categoryId is not the ID of a category that can be used for an embedded ScheduleDefinition in this ScheduleDefinition.
ArgumentNullException A non-optional argument was null
InvalidOperationException This ScheduleDefinition is not a kind of schedule that supports adding an embedded ScheduleDefinition. -or- This ScheduleDefinition already has an embedded ScheduleDefinition.
See Also