Gets the BuiltInParameter value corresponding to built-in parameter identified by the given ForgeTypeId.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- parameterTypeId
- Type: Autodesk.Revit.DB ForgeTypeId
The parameter identifier.
Return Value
The BuiltInParameter value corresponding to the given parameter identifier.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | parameterTypeId is not a built-in parameter identifier. See IsBuiltInParameter(ForgeTypeId) and GetParameterTypeId(BuiltInParameter). |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |