GetBuiltInParameter Method


Parameter Utils Get Built In Parameter Method

Gets the BuiltInParameter value corresponding to built-in parameter identified by the given ForgeTypeId.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static BuiltInParameter GetBuiltInParameter(
	ForgeTypeId parameterTypeId
)

Parameters

parameterTypeId ForgeTypeId
The parameter identifier.

Return Value

BuiltInParameter
The BuiltInParameter value corresponding to the given parameter identifier.
Exceptions
Exception Condition
ArgumentException parameterTypeId is not a built-in parameter identifier. See IsBuiltInParameter(ForgeTypeId) and GetParameterTypeId(BuiltInParameter).
ArgumentNullException A non-optional argument was NULL
See Also