Creates a circle light shape object with the given emit diameter.
Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- emitDiameter
- Type: System Double
The emit diameter as a numerical value in feet between 1.0e-9 and 30000.0
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | The shape dimension is not valid because it is not between 1.0e-9 and 30000.0. |