CircleLightShape Constructor (Double)


Creates a circle light shape object with the given emit diameter.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public CircleLightShape(
	double emitDiameter
)
Visual Basic
Public Sub New ( _
	emitDiameter As Double _
)
Visual C++
public:
CircleLightShape(
	double emitDiameter
)

Parameters

emitDiameter
Type: SystemDouble
The emit diameter as a numerical value in feet between 1.0e-9 and 30000.0

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException The shape dimension is not valid because it is not between 1.0e-9 and 30000.0.

See Also