Checks whether the element type id is valid for the give DefaultElmentType id.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- defaultTypeId
- Type: Autodesk.Revit.DB ElementTypeGroup
The default element type id.
- typeId
- Type: Autodesk.Revit.DB ElementId
The element type id.
Return Value
True if the element type id is valid for the give DefaultElmentType id, false otherwise.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |