IsDefaultElementTypeIdValid Method


Document Is Default Element Type Id Valid Method

Checks whether the element type id is valid for the give DefaultElmentType id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsDefaultElementTypeIdValid(
	ElementTypeGroup defaultTypeId,
	ElementId typeId
)

Parameters

defaultTypeId ElementTypeGroup
The default element type id.
typeId ElementId
The element type id.

Return Value

Boolean
True if the element type id is valid for the give DefaultElmentType id, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also