IsDefaultElementTypeIdValid Method


Checks whether the element type id is valid for the give DefaultElmentType id.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public bool IsDefaultElementTypeIdValid(
	ElementTypeGroup defaultTypeId,
	ElementId typeId
)
Visual Basic
Public Function IsDefaultElementTypeIdValid ( _
	defaultTypeId As ElementTypeGroup, _
	typeId As ElementId _
) As Boolean
Visual C++
public:
bool IsDefaultElementTypeIdValid(
	ElementTypeGroup defaultTypeId, 
	ElementId^ typeId
)

Parameters

defaultTypeId
Type: Autodesk.Revit.DBElementTypeGroup
The default element type id.
typeId
Type: Autodesk.Revit.DBElementId
The element type id.

Return Value

True if the element type id is valid for the give DefaultElmentType id, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also