Adjusts the length for the specified connector.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- partConn
- Type: Autodesk.Revit.DB Connector
# The connector of the fabrication part to adjust length.
- lengthToAdjust
- Type: System Double
The length to adjust.
- totalLengthOnly
- Type: System Boolean
True if adjust the total length only when adjust length.
Return Value
The adjusted length.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The end of the fabrication part of the connector can not be adjusted. -or- Connector is connected. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |