AdjustEndLength Method


Adjusts the length for the specified connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public double AdjustEndLength(
	Connector connector,
	double lengthToAdjust,
	bool totalLengthOnly
)
Visual Basic
Public Function AdjustEndLength ( _
	connector As Connector, _
	lengthToAdjust As Double, _
	totalLengthOnly As Boolean _
) As Double
Visual C++
public:
double AdjustEndLength(
	Connector^ connector, 
	double lengthToAdjust, 
	bool totalLengthOnly
)

Parameters

connector
Type: Autodesk.Revit.DBConnector
# The connector of the fabrication part to adjust length.
lengthToAdjust
Type: SystemDouble
The length to adjust.
totalLengthOnly
Type: SystemBoolean
True if adjust the total length only when adjust length.

Return Value

The adjusted length.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The end of the fabrication part of the connector can not be adjusted. -or- Connector is connected.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also