Fabrication |
Adjusts the length for the specified connector.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public double AdjustEndLength(
Connector connector,
double lengthToAdjust,
bool totalLengthOnly
)
Parameters
- connector Connector
- # The connector of the fabrication part to adjust length.
- lengthToAdjust Double
- The length to adjust.
- totalLengthOnly Boolean
- True if adjust the total length only when adjust length.
Return Value
DoubleThe adjusted length.

Exception | Condition |
---|---|
ArgumentException | The end of the fabrication part of the connector can not be adjusted. -or- Connector is connected. |
ArgumentNullException | A non-optional argument was null |