Reads content from a file of IFC format.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- readOptions
- Type: Autodesk.Revit.DB.IFC IFCFileReadOptions
The IFC file read options.
- pNumErrors
- Type: System Int32 %
The number of errors reported during the read process. The actual messages will be in the log file.
- pNumWarnings
- Type: System Int32 %
The number of warnings reported during the read process. The actual messages will be in the log file.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions InvalidOperationException | Error reading opening model for unzipping. Error reading IFC file. |