Reads content from a file of IFC format.
Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- readOptions
- Type: Autodesk.Revit.DB.IFCIFCFileReadOptions
The IFC file read options.
- pNumErrors
- Type: SystemInt32%
The number of errors reported during the read process. The actual messages will be in the log file.
- pNumWarnings
- Type: SystemInt32%
The number of warnings reported during the read process. The actual messages will be in the log file.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | Error reading opening model for unzipping. Error reading IFC file. |