Read Method (IFCFileReadOptions, Int32, Int32)


IFCFile Read(IFCFile Read Options, Int 32 , Int 32 ) Method

Reads content from a file of IFC format.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void Read(
	IFCFileReadOptions readOptions,
	out int pNumErrors,
	out int pNumWarnings
)

Parameters

readOptions IFCFileReadOptions
The IFC file read options.
pNumErrors Int32
The number of errors reported during the read process. The actual messages will be in the log file.
pNumWarnings Int32
The number of warnings reported during the read process. The actual messages will be in the log file.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException Error reading opening model for unzipping. Error reading IFC file.
See Also