Adds a leader to the text note.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- leaderType
- Type: Autodesk.Revit.DB TextNoteLeaderTypes
Type of the leader being added.
Return Value
The newly added leader.Remarks
If the geometric type of the new leader (line vs arc.) differs from the type of existing leaders, then the type of the existing leaders will be changed to match the type of the newly created leader.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |