AddLeader Method


Text Note Add Leader Method

Adds a leader to the text note.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Leader AddLeader(
	TextNoteLeaderTypes leaderType
)

Parameters

leaderType TextNoteLeaderTypes
Type of the leader being added.

Return Value

Leader
The newly added leader.
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Remarks
If the geometric type of the new leader (line vs arc.) differs from the type of existing leaders, then the type of the existing leaders will be changed to match the type of the newly created leader.
See Also