AddLeader Method


Adds a leader to the text note.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public Leader AddLeader(
	TextNoteLeaderTypes leaderType
)
Visual Basic
Public Function AddLeader ( _
	leaderType As TextNoteLeaderTypes _
) As Leader
Visual C++
public:
Leader^ AddLeader(
	TextNoteLeaderTypes leaderType
)

Parameters

leaderType
Type: Autodesk.Revit.DBTextNoteLeaderTypes
Type of the leader being added.

Return Value

The newly added leader.

Remarks

If the geometric type of the new leader (line vs arc.) differs from the type of existing leaders, then the type of the existing leaders will be changed to match the type of the newly created leader.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also