Returns settings element by name.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 23.0.0.0 (23.1.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document to find the settings with the specified name.
- name
- Type: System String
Name of the settings to find.
Return Value
The settings element, or a null reference ( Nothing in Visual Basic) if not found.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |