FindByName Method


Returns settings element by name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public static ExportPDFSettings FindByName(
	Document document,
	string name
)
Visual Basic
Public Shared Function FindByName ( _
	document As Document, _
	name As String _
) As ExportPDFSettings
Visual C++
public:
static ExportPDFSettings^ FindByName(
	Document^ document, 
	String^ name
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document to find the settings with the specified name.
name
Type: SystemString
Name of the settings to find.

Return Value

The settings element, or a null reference (Nothing in Visual Basic) if not found.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~".
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also