SetDescription Method


Set the description for an existing family parameter. The description will be used as tooltip in the Revit UI including in the properties palette.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015

Syntax

C#
public void SetDescription(
	FamilyParameter familyParameter,
	string description
)
Visual Basic
Public Sub SetDescription ( _
	familyParameter As FamilyParameter, _
	description As String _
)
Visual C++
public:
void SetDescription(
	FamilyParameter^ familyParameter, 
	String^ description
)

Parameters

familyParameter
Type: Autodesk.Revit.DB FamilyParameter
The family parameter.
description
Type: System String
The description of the family parameter.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException Thrown when the input argument-"familyParameter"-is a null reference ( Nothing in Visual Basic) .
Autodesk.Revit.Exceptions ArgumentException Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter.

See Also