SetDescription Method


Family Manager Set Description Method

Set the description for an existing family parameter. The description will be used as tooltip in the Revit UI including in the properties palette.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetDescription(
	FamilyParameter familyParameter,
	string description
)

Parameters

familyParameter FamilyParameter
The family parameter.
description String
The description of the family parameter.
Exceptions
Exception Condition
ArgumentNullException Thrown when the input argument-"familyParameter"-is .
ArgumentException Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter.
See Also