Set the description for an existing family parameter. The description will be used as tooltip in the Revit UI including in the properties palette.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- familyParameter
- Type: Autodesk.Revit.DBFamilyParameter
The family parameter.
- description
- Type: SystemString
The description of the family parameter.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | Thrown when the input argument-"familyParameter"-is a null reference (Nothing in Visual Basic). |
Autodesk.Revit.ExceptionsArgumentException | Thrown when the input argument-"familyParameter"-is an invalid parameter or a builtIn parameter. |