Creates a new Extrusion Roof.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- profile
- Type: Autodesk.Revit.DB CurveArray
The profile of the extrusion roof. The curves of the profile must be contiguous and form one open loop without self-intersections. The profile curves must lie in the %refPlane% parallel to z-axis.
- refPlane
- Type: Autodesk.Revit.DB ReferencePlane
The work plane for the extrusion roof. It must be parallel to z-axis.
- level
- Type: Autodesk.Revit.DB Level
The level of the extrusion roof.
- roofType
- Type: Autodesk.Revit.DB RoofType
Type of the extrusion roof.
- extrusionStart
- Type: System Double
Start the extrusion. Measured from %refPlane% in the direction of the plane normal.
- extrusionEnd
- Type: System Double
End the extrusion. Measured from %refPlane% in the direction of the plane normal.
Remarks
This method will regenerate the document even in manual regeneration mode.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown if the work plane does not exist in the given document. |
Autodesk.Revit.Exceptions ArgumentException | Thrown if the level does not exist in the given document. |
Autodesk.Revit.Exceptions ArgumentException | Thrown if the roof type does not exist in the given document. |