Creates a new Extrusion Roof.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- profile
- Type: Autodesk.Revit.DBCurveArray
The profile of the extrusion roof. The curves of the profile must be contiguous and form one open loop without self-intersections. The profile curves must lie in the %refPlane% parallel to z-axis.
- refPlane
- Type: Autodesk.Revit.DBReferencePlane
The work plane for the extrusion roof. It must be parallel to z-axis.
- level
- Type: Autodesk.Revit.DBLevel
The level of the extrusion roof.
- roofType
- Type: Autodesk.Revit.DBRoofType
Type of the extrusion roof.
- extrusionStart
- Type: SystemDouble
Start the extrusion. Measured from %refPlane% in the direction of the plane normal.
- extrusionEnd
- Type: SystemDouble
End the extrusion. Measured from %refPlane% in the direction of the plane normal.
Remarks
This method will regenerate the document even in manual regeneration mode.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | Thrown if the work plane does not exist in the given document. |
Autodesk.Revit.ExceptionsArgumentException | Thrown if the level does not exist in the given document. |
Autodesk.Revit.ExceptionsArgumentException | Thrown if the roof type does not exist in the given document. |