Document New |
Creates a new Extrusion Roof.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public ExtrusionRoof NewExtrusionRoof(
CurveArray profile,
ReferencePlane refPlane,
Level level,
RoofType roofType,
double extrusionStart,
double extrusionEnd
)
Parameters
- profile CurveArray
- The profile of the extrusion roof. The curves of the profile must be contiguous and form one open loop without self-intersections. The profile curves must lie in the %refPlane% parallel to z-axis.
- refPlane ReferencePlane
- The work plane for the extrusion roof. It must be parallel to z-axis.
- level Level
- The level of the extrusion roof.
- roofType RoofType
- Type of the extrusion roof.
- extrusionStart Double
- Start the extrusion. Measured from %refPlane% in the direction of the plane normal.
- extrusionEnd Double
- End the extrusion. Measured from %refPlane% in the direction of the plane normal.
Return Value
ExtrusionRoof
Exception | Condition |
---|---|
ArgumentException | Thrown if the work plane does not exist in the given document. |
ArgumentException | Thrown if the level does not exist in the given document. |
ArgumentException | Thrown if the roof type does not exist in the given document. |

This method will regenerate the document even in manual regeneration mode.