SetElementIdValue Method


Sets new ElementId value of entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2022

Syntax

C#
public void SetElementIdValue(
	ElementId value
)
Visual Basic
Public Sub SetElementIdValue ( _
	value As ElementId _
)
Visual C++
public:
void SetElementIdValue(
	ElementId^ value
)

Parameters

value
Type: Autodesk.Revit.DB ElementId

Remarks

You should only use this method if the StorageType property reports the type of the entry as a ElementId.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null
Autodesk.Revit.Exceptions InvalidOperationException The entry has different storage type with ElementId.

See Also