SetElementIdValue Method


Sets new ElementId value of entry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public void SetElementIdValue(
	ElementId value
)
Visual Basic
Public Sub SetElementIdValue ( _
	value As ElementId _
)
Visual C++
public:
void SetElementIdValue(
	ElementId^ value
)

Parameters

value
Type: Autodesk.Revit.DBElementId

Remarks

You should only use this method if the StorageType property reports the type of the entry as a ElementId.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException The entry has different storage type with ElementId.

See Also