Exports the current view or a selection of views in SAT format.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- folder
- Type: System String
Output folder, into which file(s) will be exported. The folder must exist.
- name
- Type: System String
Either the name of a single file or a prefix for a set of files. If empty, automatic naming will be used.
- views
- Type: System.Collections.Generic ICollection ElementId
Selection of views to be exported. The set must contain at least one valid view.
- options
- Type: Autodesk.Revit.DB SATExportOptions
Various options applicable to the SAT format.For now, this option is empty. If a null reference ( Nothing in Visual Basic) , all options will be set to their respective default values.
Return Value
True if successful, otherwise False.Remarks
All the views must be 3D views for the Export to succeed.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | NullOrEmpty -or- Contains invalid characters. -or- non empty list of views must be provided. -or- At least one provided viewId is an id of a non-3D view. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |
Autodesk.Revit.Exceptions DirectoryNotFoundException | Thrown when the directory does not exist. |
Autodesk.Revit.Exceptions ForbiddenForDynamicUpdateException | This method may not be called during dynamic update. |
Autodesk.Revit.Exceptions InvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode. |
Autodesk.Revit.Exceptions InvalidPathArgumentException | The folder does not exist. |
Autodesk.Revit.Exceptions OptionalFunctionalityNotAvailableException | The ShapeExporter functionality is not available in the installed Revit. |