Exports the current view or a selection of views in SAT format.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- folder
- Type: SystemString
Output folder, into which file(s) will be exported. The folder must exist.
- name
- Type: SystemString
Either the name of a single file or a prefix for a set of files. If empty, automatic naming will be used.
- views
- Type: System.Collections.GenericICollectionElementId
Selection of views to be exported. The set must contain at least one valid view.
- options
- Type: Autodesk.Revit.DBSATExportOptions
Various options applicable to the SAT format.For now, this option is empty. If a null reference (Nothing in Visual Basic), all options will be set to their respective default values.
Return Value
True if successful, otherwise False.Remarks
All the views must be 3D views for the Export to succeed.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | NullOrEmpty -or- Contains invalid characters. -or- non empty list of views must be provided. -or- At least one provided viewId does not correspond to a printable 3D view. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsDirectoryNotFoundException | Thrown when the directory does not exist. |
Autodesk.Revit.ExceptionsForbiddenForDynamicUpdateException | This method may not be called during dynamic update. |
Autodesk.Revit.ExceptionsInvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode. |
Autodesk.Revit.ExceptionsInvalidPathArgumentException | The folder does not exist. |
Autodesk.Revit.ExceptionsOptionalFunctionalityNotAvailableException | The ShapeExporter functionality is not available in the installed Revit, or the Material Library is missing. |