Creates a new instance of this view (using specific template)
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- ADoc
- Type: Autodesk.Revit.DB Document
The Document
- templateId
- Type: Autodesk.Revit.DB ElementId
The templateId that this function will use
- panelId
- Type: Autodesk.Revit.DB ElementId
Element id of the electrical panel element.
Return Value
The PanelScheduleViewExceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |