Creates a new instance of this view (using specific template)
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- ADoc
- Type: Autodesk.Revit.DBDocument
The Document
- templateId
- Type: Autodesk.Revit.DBElementId
The templateId that this function will use
- panelId
- Type: Autodesk.Revit.DBElementId
Element id of the electrical panel element.
Return Value
The PanelScheduleViewExceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |