Gets the dimmer value for the given light for rendering the given view
Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- viewId
- Type: Autodesk.Revit.DB ElementId
The Id of the view
- lightId
- Type: Autodesk.Revit.DB ElementId
The Id of the light to turn on or off
Remarks
The dimmer value is in the range [0.0, 1.0] with 0.0 being totally dimmed and 1.0 being totally on
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The given element Id does not correspond to a 3d view -or- The given element Id does not correspond to a light instance |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was null |