GetLightDimmer Method


Light Group Manager Get Light Dimmer Method

Gets the dimmer value for the given light for rendering the given view

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double GetLightDimmer(
	ElementId viewId,
	ElementId lightId
)

Parameters

viewId ElementId
The Id of the view
lightId ElementId
The Id of the light to turn on or off

Return Value

Double
Exceptions
Exception Condition
ArgumentException The given element Id does not correspond to a 3d view -or- The given element Id does not correspond to a light instance
ArgumentNullException A non-optional argument was null
Remarks
The dimmer value is in the range [0.0, 1.0] with 0.0 being totally dimmed and 1.0 being totally on
See Also